Getting Alamofire to install and build correctly on Xcode 8 and Swift 3 can be challenging (due most likely to the rapid changes going on in the Swift 3 language as well as the fairly rapid catch-up efforts going on in the Alamofire codebase).

Because I struggled with this myself on three different projects (with three different experiences!), I decided to document my understanding of the steps that worked. This is both to remind me and to share with others who have the unpleasant experience of adding Alamofire to their project and then seeing 600+ “errors” at build time.

Instructions

Hope this helps!